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EAME Earth and Marine Environmental 
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CI-Guyana Conservation International Guyana 

GIS Geographic Information System 

GMW Global Mangrove Watch 
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Landsat TM Landsat Thematic Mapper 
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NDVI Normalised Difference Vegetation Index 
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 Introduction 

1.1 Project Background  
 

The project titled, “Setting the foundations for zero net loss of the mangroves that underpin human wellbeing 

in the North Brazil Shelf Large Marine Ecosystem (NBS Mangrove Project)”, is a one-year primer project to 

help establish a shared and multi-national process for an Integrated Coastal Management (ICM) in the NBS 

through research and regional coordination. The project was implemented through a collaboration between 

the International Union for the Conservation of Nature South America (IUCN-Sur), Conservation 

International Americas Field Division (CI-AFD), together with Conservation International Guyana (CI-

Guyana) and Suriname (CI-Suriname), and other partners and is also funded by the Global Environment 

Facility (GEF). Under its International Waters Focal Area, the Global Environment Facility (GEF) helps 

countries to collectively and sustainably manage their transboundary surface water basins, groundwater 

basins, and coastal and marine ecosystems. 

In Guyana, CI is collaborating with the Mangrove Department of the National Agricultural Research and 

Extension Institute to implement the project. Suriname has the following co-financing partners: UNDP 

Suriname, WWF-Guianas, and The Foundation for Forest Management & Production Control (Stichting 

Bosbeheer en Bostoezicht (SBB). In Suriname, mangrove cover mapping was conducted by the SBB in 

partnership with CI Suriname.  

On July 26th, 2010, Guyana Forestry Commission (GFC) and NARI (National Agriculture Research 

Institute) signed a Memorandum of Understanding (MOU). Under the agreement, the Government of 

Guyana, through NARI, provided GFC with funding for the implementation of the Mangrove Species 

Inventory Program.  

The undertakings were to inventories approximately 470 kilometers of mangrove forest coastline in Guyana, 

annually, for an initial period of three years. High resolution satellite images were used to calculate the 

coastal zone forest area in Guyana. This was derived from the semiautomated interpretation of the Satellite 

images which provides the extent of the forest along the entire coastline and also gives a detail breakdown 

by administrative regions. 

The total forested area at this point is estimated at22,632 ha (55,925 ac). This area is less than previous 

coastal zone forest estimates as reported by FAO in 1990, which was at 91,000 ha and Dr. Hans ter Steege 

in 2001 as 80,432 ha. [See full report: Mapping and Inventory of Coastal Zone Forests in Guyana, South 

America, 2011].  

Earth and Marine Environmental Consultants (EAME) was commissioned to undertake Mangrove Cover 

analysis across Guyana’s coastline on behalf of the project. This report is the Implementation Report 

providing supporting discussion for the data acquisition and processing utilised in order to produce the 

Mangrove Cover Extent Map. 
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 Methodology 

EAME’s developed methodology has been produced using the following software:  

▪ SNAP Sentinel toolbox;  

▪ QGIS (versions 2.18 and upwards); and 

▪ Microsoft Excel Package. 

2.1 Software download 
This section will provide a step by step guide in order to download the software used by EAME to produce 

a Mangrove extent map.  

Determining Computer ‘Bit’ size 

The ‘Bit’ size of your computer will determine which selection to make when it comes to downloading 

software in the subsequent stages. If you already know the ‘Bit’ size of your computer, then you can skip 

this section and continue straight to Section 0.  

Determining the ‘Bit’ size of a Windows 10 computer 

1. Click start > Select System > Select About 

2. The ‘Bit’ size of the computer should be shown under ‘Device Specifications’ under system type. 

Determining the ‘Bit’ size of a Windows 8 computer 

1. Click Start > Control Panel > System 

2. The ‘Bit’ size should be shown under ‘System Type’. 

Snap Sentinel toolbox  

SNAP Sentinel Toolbox is a multi-mission, open source, remote sensing software, supporting data such as 

RapidEye, SPOT, MODIS, Landsat (TM), etc. EAME used SNAP Sentinel toolbox in order to conduct the 

remote sensing aspect of the Project and produce a classified image. 

1. Copy the following URL Link and search on the internet: 

http://step.esa.int/main/download/snap-download/  

2. Dependent upon the ‘Bit’ size of your computer, select the appropriate download option. The 

download should begin. 

3. Once the download has completed, open Snap. An installing wizard should open, which will 

help guide you through the rest of the process. 

4. Once you have followed the installation, Snap has downloaded and ready for use. 

QGIS 

 

http://step.esa.int/main/download/snap-download/
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QGIS is a user friendly, open source Geographic Information System, which supports numerous vector, 

raster and database formats and functionalities. It runs on Linux, Unix, Mac, OSX, Windows and Android 

(QGIS, 2019). EAME used QGIS 3.4 (long term release) in order to conduct GIS analysis on the classified 

images.  

1. Copy this link into a web browser: http://download.osgeo.org/qgis/; 

2. Dependent upon the ‘Bit’ size of your computer, you need to select the correct link: 

  

If you have a 32 bit computer, choose the ‘win32/’ option. If you have a 64 bit computer, choose ‘win64/’.  

3. Scroll down the Page until you come to ‘QGIS-OSGeo4W-3.4.10-Setup-x86_64.exe’ with 

the date of ‘2019-Jul-20 11:53’. Click on the QGIS setup link. 

4. Save the setup link to an area on your desktop. 

5. Go to the file directory by which the setup link is saved. Double click on this. 

6. Allow the setup link to make changes to your computer. 

7. The setup should begin. Once complete, open QGIS. This can be either done by going to 

the Start menu and searching for QGIS or by a shortcut which may have appeared on your 

desktop. 

Microsoft Excel 

If you do not have a Microsoft package installed on your computer, you can purchase and download the 

package from this link: https://products.office.com/en-gb/. 

 

2.2 Software Setup 
 

2.2.1 QGIS Properties and Plugin Installation 

In order to perform all required functions within QGIS a number of procedures must be undertaken at the 

start of each project: 

 

http://download.osgeo.org/qgis/
https://products.office.com/en-gb/compare-all-microsoft-office-products?&icid=CNavSoftwareOffice&rtc=1&activetab=tab%3aprimaryr1
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QGIS 3.4.10 with Grass 7.6.1 

When downloading the correct version of QGIS as described in the sections above, the complementary 

software package GRASS will also have downloaded. Options are available to open each software package 

individually or to open “QGIS Desktop 3.4.10 with GRASS 7.6.1”. One of the functions described in the 

later stages of the below methodology requites that this option has been selected. Therefore, EAME 

recommends opening the “QGIS Desktop 3.4.10 with GRASS 7.6.1” every time the methodology requires 

work in QGIS. 

Setting the project CRS  

In order to ensure consistency and accuracy all layers must work in the same Co-ordinate Reference 

System (EAME used WGS 84/ UTM zone 21N (ESPG: 32621)). In addition, the project CRS must be set to 

correspond. To do this: 

1. Click on the Project tab in the top left corner; 

2. Open Properties; 

3. Open the CRS tab in the pop-up window, 

  

4. Select the preferred CRS and click apply. 

Setting the project measurements 

Too complete tasks required in this methodology (such as calculating areas) project measurement units 

must be set to provide consistency between layers. EAME used kilometres for distance measurements and 

hectares for area measurements. To do this: 

1. Click on the Project tab in the top left corner; 

2. Open Properties; 

3. Open the General tab in the pop-up window; 
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4. Use the drop down selection boxes in the measurements window to select preferred distance 

and area units. 

 

Plug-ins 

QGIS is an open software for which users and independent organisations are free to develop ‘plugins’, 

designed to provide additional functionality to the QGIS platform. In order to successfully complete all tasks 

throughout the following methodology it is important to ensure two plugins are installed, up-to-date and 

switched on. The two plugins that must be installed and up-dated are entitled ‘Processing’ and ‘Digitizing 

Tools’. The steps to install and ensure they are kept up-to-date are as follows: 

1. Select “Plugins” from the tool bar 

2. Select “Manage and Install Plugins…”;   

3. Ensure the “All” tab is select to the left of the pop-up window and search for the plug-in name 

in the search bar at the top of the window; 

4. From the available plug-ins select the desired option and click “Install Plugin” found at the 

bottom right of the pop-up; 

5. Allow plug-in to install and then ensure that the check box to the left of the plugin name is ticked, 

indicating the plugin is switched on. 
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2.1 Determination of Mangrove Extent 

Mapping mangrove forests and conducting cover extent analysis requires four main steps: 

1. Data pre-processing and collection; 

2. Image Classification; 

3. An accuracy assessment of classification results; and 

4. Conducting change detection analysis. 

Downloading raw Satellite Imagery 

EAME acquired Sentinel-2 satellite imagery from The Copernicus Open Access Hub. The Copernicus 

Sentinel-2 mission involved two satellites; Sentinel-2A, which was launched on the 22nd of June 2015, and 

Sentinel-2B, which was launched on the 7th of March 2017 (Copernicus, 2019) Sentinel-2 includes 13 

spectral bands, four of which are at a 10m resolution, six at a 20m resolution and three bands at a 60m 

resolution.  

Free to download Sentinel 2 Satellite Imagery is available to download from: https://scihub.copernicus.eu/. 

1. Copy and paste the above link into a web browser. The Copernicus Open Access hub should 

have opened. 

2. Select the ‘Open Hub’ option (it can quickly be accessed via this link: 

https://scihub.copernicus.eu/dhus/#/home). 

3. In order to download the Sentinel 2 data, you must make an account with the Copernicus Open 

Access Hub. To do this, click on this icon:  

4. Click on sign up and fill in relevant details in order to create an account. A validation email will 

be sent to the email account you used to register with. 

5. Upon completion of registration, you can search for areas of interest via the search bar or by 

moving around to the area of interest using the pan tool. You can select the drawing tool  

and draw a shape around the area of interest. 

6. Once satisfied with the selection, click the search option . 

7. All Sentinel images found within the search will be displayed. 

8. These image search can be narrowed by selecting the  tool. The following display is then 

shown: 

https://scihub.copernicus.eu/
https://scihub.copernicus.eu/dhus/#/home
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9. Select the desired parameters, such as the date in which the desired satellite imagery was 

taken, which Sentinel mission the image was acquired from, etc. 

10. Once satisfied with the parameters, select the search icon. 
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11. The images will be displayed similar to this: 

 

12. When hovering over each satellite image, a series of icons are shown:  

 

13. This tool  allows the user to zoom to the product. This tool  allows the user to view details 

of the product (which is opened in a separate dialogue). This tool  allows the user to add 

the satellite image to the cart. Finally, this tool  allows the user to directly download the 
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product. Using these tools will help select the most appropriate product within the area of 

interest. 

14. If the product is satisfactory and would like to be downloaded, select  and the image will 

download. 

Pre-processing 

Due to project constraints on the project, EAME made use of proprietary, pre-processed imagery. 

The following pre-processing tasks were undertaken for each proprietary image: 

▪ Acquisition of Sentinel-2 satellite imagery; 

▪ Cloud identification; 

▪ Creation of a cloud mask; 

▪ Cloud removal; and 

▪ Replacement by mosaicking other cloud-free satellite imagery.  

The result was a series of composite images along the Guyanese coastline (see Table Error! No text of 

specified style in document..1). 

Table Error! No text of specified style in document..1: Satellite imagery information associated with each 

composite image. 

Satellite Image Name Primary Image Date Secondary Image Dates 

S2_T20PRQ_20180401_21N 2018-03-01 
2018-02-20, 2018-10-

08, 2018-09-13 

S2_T21NTJ_20180220 2018-02-20 2017-12-17 

S2_T21NUJ_20180620 2018-06-20 2017-12-17 

S2_T21NUH_20180322 2018-03-22 2018-02-20, 2018-07-05 

S2_T21NVH_20181025 2018-10-25 2018-10-15 

S2_T21NVG_20181025 2018-10-25 2018-10-10 

 

Image Classification 

EAME used SNAP Sentinel toolbox in order to classify each image. EAME had adopted a 10km buffer along 

the shoreline of Guyana, in order to reduce the total area being classified (Kirui, et al., 2013) as well as to 

reduce the interference of other land types, such as rainforest. Moreover, EAME have used a three class 
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system (Mangrove, Water, and Other Land Cover) (Thomas, et al., 2018) to also reduce interference 

between classes, which may have occurred when conducting a land cover classification.  

Due to restrictions in the project timeline, EAME were unable to generate any training data to feed into the 

classification process, therefore the most current data provided by Global Mangrove Watch (Thomas, et 

al., 2018), was used as training data for mangroves. The random forest classifier was used within Snap 

Sentinel toolbox when classifying the images of Guyana’s coastline (Thomas, et al., 2018), as this classifier 

incorporated various indices, such as NDVI and NDWI. 

Within this section, EAME has included a step-by-step guide which was used in order to determine 

mangrove cover extent along the Guyanese coastline. 

Converting File format for SNAP Sentinel Toolbox Compatibility 

1. Open SNAP Sentinel Toolbox; 

2. Load the pre-processed ‘.tiff’ file into snap via this button: ; 

3. A dialogue should open;   

4. Select the correct file and click ‘Open’; 

5. Once the File has loaded, which is shown in the ‘Product Explorer’ tab;

 

6. SNAP Sentinel toolbox operates using .dim files (which are composed of the ‘.dim file’ and an 

associated ‘.data’ file). We currently have imported a ‘.tiff’ file and need to convert this in order to 

perform classification. Right click on the ‘.tiff’ file within the ‘Product Explorer’ tab; 
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7. Select ‘Save Product As’. A dialogue will open, select “Yes”; 

  

8. Select the relevant location to save your ‘.dim’ and associated ‘.data’ file. Click ‘Save.  

Clipping to a 10km Area 

1. Open RGB Window by right clicking on the file> select Open RGB Window> Select bands you want 

to display> Click ok; 

2. Load vector file into SNAP. Click ‘Vector’ > ‘Import’> ‘Esri Shapefile’; 

3. Select ‘10km extent shapefile’; 

4. Click ‘open’; 

5. Click ‘Raster tab’; 

6. Click ‘masks’; 

7. Click ‘Land/Sea Mask’ a dialogue will open;  
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8. Change the name of the output and directory if needed; 

9. Select ‘processing parameters’ tab; 
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10. Select ‘Use Vector as Mask’; 

11. Select the 10km shoreline buffer. 

Generation of Vegetation Indices 

1. In product explorer tab, right click and select band maths; 

2. A dialogue will open; 
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3. Under name, name the output file. Add a description if you also wish; 

4. Click on ‘edit expression’ button. A new dialogue will open; 
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5. Insert your expression dependent upon which indices you wish to calculate. For example, to 

calculate NDVI the expression is (NIR-R)/(NIR+R). In the band expression this would equate to 

(Band 7- band 3)/ (band 7+ band 3); 

6. Click ok; 

7. Click ok again; 

8. The band expression should be loaded into the product explorer. 

Table Error! No text of specified style in document..2: Indices and corresponding formulae in SNAP Sentinel 

Toolbox. 

Indices Name Indices Formula in SNAP 

NDVI (band_7 - band_3)/ (band_7 + band_3) 

NDWI (band_2 - band_7) / (band_2 + band_7) 

BSI ((band_9 + band_3) - (band_7 + band_1)) / ((band_9 + band_3) 

+ (band_7 + band_1)) 

 

Generation of Regions of Interest 

1. Select the ‘Vector’ tab; 

2. Select new vector data container; 

3. The below dialog box is available;  

4. Enter name of training class and description if desired; 

5. Click Ok; 

6. Select one of these tools . And draw your training polygons;  

7. Repeat these steps until all of your desired classes are created; 
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Note: all classes must be created in SNAP in the same order. This will ensure that the values generated 

after the classification has taken place are all the same between each image. This will become beneficial 

when manually manipulating the images in QGIS (later step). 

Running Random Forest Classifier 

1. Before running the classification, you should have your image which include training ROIs and 

indices if required; 

2. Select ‘Raster’ on menu tab; 

3. Select ‘Classification’; 

4. Select ‘Supervised Classification’; 

5. Select ‘Random Forest Classifier’. A dialogue will open; 

6. Add file that random forest will be run on; 

7. Select ‘Random-Forest Classifier’ tab; 

8. Ensure all classes that you would like to include are shown in the ‘Vector Training’ box; 

9. Ensure all the correct bands (including indices if you have generated any) appear in the ‘Feature 

Selection’ box; 

10. Click on the ‘Write’ Tab; 

11. Change the name and output directory of the output file; 

12. Click ‘Run’ button. 

Repeat the above steps for all image tiles across Guyana’s coastline. 

Exporting Classified Image in SNAP 

This section outlines how to export a .dim file into a GEOTIFF file.  

1. Select the .dim file in the product explorer tab in SNAP; 

2. Click on ‘File’ on the menu bar; 

3. Click on ‘Export’; 

4. Choose ‘GEOTIFF’. A dialogue will open; 

5. Search and choose the appropriate output directory; 

6. Click Export. 
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Manual Refinement/ Manipulation 

EAME further edited the classification results to refine the shape of the mangrove cover and the resulting 

accuracy. This process was done manually on a vector shapefile of the classified results by visual 

interpretation (Omar, et al., 2019) in QGIS. 

File Format Conversion within QGIS 

1. Import geotiff into QGIS; 

2. Convert into vector by selecting ‘Raster> Conversion> Polygonize. A dialogue will open;

 

3. Select the correct ‘Input Layer’, i.e. the geotiff (raster) which you want to change into a vector 

format. Select the  button and choose the correct output directory for the resulting file. 

Ocean Removal in QGIS 

1. Click on the recently vectorized file. Using the Selection tool: , select the ocean; 

2. Using the Expression Selection tool (see image below), click the drop down arrow and select Invert 

Feature Selection; 
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3. Open the attribute table for the selected Vector file by Right clicking on the vector file> Select ‘Open 

Attribute Table’. The attribute table should be opened in a new dialogue; 

4. Select the toggle editing tool .  All of the selected features should be highlighted in Blue; 

5. Delete the Selected files from the attribute table by clicking on the  button. Click on the Save 

button . Then deselect the toggle editing tool. Once this is completed, the ocean should no 

longer be selectable/ shown within the vector file. 

Landcover Field Creation  

This stage will develop a new, descriptive Landcover field based on the existing DN values. The current 

shapefile contains many features but only one field value for each. This is the DN value generate during the 

SNAP classification process. For this stage the values and how they correspond to land covers must have 

already been recorded during the classification stage. The process will use this DN value to designate a 

description in a new Landcover field. To do this: 

1. Open the relevant, newly classified shapefile; 

2. Right click on the shapefile in the layers viewer panel and “Open attribute table”; 

3. Open the field calculator ; 

4. Ensure the “Create a new field” box is checked; 

5. Enter “Landcover” into “Output field name”; 

6. Select “Text (string)” in output field type; 

7. Define appropriate no. of characters for new field with “Output field length” (suggest 80); 

8. Type the below expression into the expression box; 

 

Case  

 When "DN" = '0' then 'Water' 

 When "DN" = '1' then 'Mangrove' 

 When "DN" = '2' then 'Other Landcover' 
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End 

N.B. this expression assumes that the DN value 0 corresponds with water, that 1 corresponds with 

mangrove and that 2 corresponds with all other landcovers. The expression must be edited where this is 

not the case so that each DN value corresponds with the appropriate landcover. 

9. Click “Ok”. 

 

Manual refinement of landcover classifications  

This process will incorporate manual consideration and expert manipulation of the existing shapefile to 

further improve the landcover classifications. 

1. Ensure the relevant shapefile is highlighted in the layers viewer panel and enable editing ; 

2. Use the “Select features by area or single click” tool to select polygons that are known to be 

incorrectly classified (selected polygons will show up yellow and the nodes will be highlighted 

as red crosses) ; 

 

N.B. the CTRL button on the keyboard can be held down to make multiple selections. 

N.B. only landcovers being re-classified to the same end landcover can be re-classified in one process. i.e. 

water and/or mangrove being re-classified to Other Landcover can be re-classified in the same process. 

Different end landcover classifications must be re-classified in different iterations of this methodology. 
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3. When the appropriate polygons are selected, open the layers attribute table  and then, from 

the attribute table, the field calculator ; 

4. Ensure that the “Only update [XXX] selected features” box is checked; 

5. Ensure that the “Update existing field” box is checked; 

6. Select the appropriate field from the dropdown box (i.e. Landcover); 

7. Type appropriate landcover class, with single quotations, into the expression box (i.e. ‘Other 

Landcover’) and click “Ok”; 
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8. Turn off editing to save these changes . 

Calculate feature areas 

In order for this to be successful, the relevant units must already be set (see Section 0). 

1. Right click on the relevant layer in the layers viewer panel; 

2. Select “Open Attribute Table”; 

 

3. Open the field calculator ; 

4. Ensure the “Create a new field” box is checked; 

5. Enter “Area” into the “Output field name” box; 
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6. Select “Decimal number (real)” from the dropdown menu; 

7. Select the preferred output length and precision (recommended 10 and 3); 

8. From the function dropdowns expand “Geometry” and double click on “$area” so that it appears 

in the expression box;  

Generating Random Points 

This section will involve using the number of points generated within the spreadsheet used in the previous 

activity.   

1. In QGIS, select a class (Mangrove, Water, Other Land Cover) within the attribute table of the 

vectorised shapefile using the filtering tool as shown in previous steps. 

2. Select ‘Vector’ menu tab 

3. Select ‘Research tools’ > Select ‘Random Points in Layer Bounds’. A new dialogue will open: 

   

4. Select the correct input layer. 

5. Tick the box ‘Select Features only’ 

6. Select the correct number of points (defined in excel spreadsheet). 

7. Select minimum distance between points as 50m. 

8. Click run 

9. The random points should be generated within the highlighted polygon. 

10. Repeat this step for all of the classes. 
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 Accuracy Assessment 

 

Cohen’s Kappa Statistical test is a measure of interrater reliability between two raters. EAME have adapted 

the use of Cohen’s Kappa in order to assess the accuracy of the classification output (Thomas, et al., 2018). 

The Accuracy assessment was undertaken using QGIS (QGIS 3.4 long term release) and Microsoft Excel. 

Generating Random Points 

300 random points were generated proportionally based on the respective areas of each landcover. The 

first stage of this process therefore was to establish the number of points per class. This stage assumes 

access to the EAME generated “019-1712 CI Guyana Mangrove Monitoring Standard Operating Procedure 

- No. of Random Points” excel file.  

1. Right click on the relevant shapefile in the layers viewer panel select Export then Save Features 

as; 

2. Under the “Format” tab, change the output format to “Comma Separated Value.csv” 

3. Select the output directory appropriately by clicking the  button next to the ‘file name’ tab. 

4. Click ‘OK’. 

5. Open the .csv file. It should open within Microsoft Excel. 

6. Highlight the data within the spreadsheet, Copy and paste this appropriately into the ready-

made spreadsheet (019-1712 CI Guyana Mangrove Monitoring Standard Operating Procedure 

- No. of Random Points) which will generate a number of points based off total area.  

N.B. EAME had set a benchmark number of random points for both the Water and Mangrove classes due 

to the Other Land Cover class covering of the majority of the area for each satellite image. In order to 

determine the accuracy of Mangrove classification, EAME had suggested 30 points as a minimum for the 

Mangrove class. The water class was given a minimum of 15 random points. 

7. In QGIS, open the layers attribute table  and then “Select by expression” ; 

8. Select a landcover class with an expression that follows the below form, then close the select 

by expression window; 

"Landcover" = 'Mangrove' 

9. Select ‘Vector’ menu tab; 

10. Select ‘Research tools’ and open ‘Random Points in Layer Bounds’; 
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11. Select the correct input layer; 

12. Tick the box ‘Select Features only’; 

13. Select the correct number of points (defined in excel spreadsheet); 

14. Select minimum distance between points as 50m; 

15. Use the button with three dots to the right of the “Random points” box to appropriately save 

the generated random points shapefile; 

16. Repeat steps 7 to 15 classes. 

Conducting Cohen’s Kappa within QGIS and Microsoft Excel 

1. Open the attribute table for one of the random point files and enable editing ; 

2. Create a new field , name it Kappa, the field type should be ‘text (string)’, choose an appropriate 

length (suggested 80) and click OK; 

3. Select one of the features within the attribute table; 

4. Press Crtl+J on the keyboard, this will zoom to the selected feature. Classify this point with the 

actual landcover classification applicable to that point; 

N.B. This process may be facilitated by expert local knowledge, consideration of the original Sentinel 

imagery and the random forests classification. 

5. Repeat steps 1-4 for all of the features within the random points file; 

6. Repeat steps 1-5 step for each random points file; 
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7. Once all of the data for Cohen’s Kappa has been collected for each random points file, input the 

data into the prepared Cohen’s Kappa Spreadsheet. Once all of the observed data has been 

inputted into the spreadsheet, the Kappa value should be automatically generated; 

8. If the Kappa result is below the acceptance level of 0.75, re-classification should be considered. 

 Mangrove Extent  

This section involved the merging of the generated mangrove extents for each satellite image, in order to 

produce a comprehensive mangrove extent shapefile.  

Extracting the Mangrove Layer from each Shapefile layer 

1. Open attribute table and select the value that represents mangroves. 

2. Close attribute table 

3. Right click on the layer 

4. Select ‘save selected features as’  

5. Save in correct output directory 

6. Click save. 

Merge all mangrove files: 

1. Open two neighbouring mangrove extent shapefiles (i.e. Mangrove layers extracted from Study 

Area 1 and Study Area 2); 

2. Select Vector menu tab; 

3. Select Geo-Processing Tools; 

4. Select Difference…; 

5. Select the first layer (i.e. Study Area 1) as the Input layer and the second layer (i.e. Study Area 

2) as the Overlay layer; 

6. Leave the Difference box as [Create temporary layer]; 

7. Ensure ‘Open output file after running algorithm’ is selected; 

8. Click ‘Run’ 

9. Working with the temporary ‘Difference Layer’, select all polygons in the overlapping regions of 

the original shapefiles (i.e. areas considered by both Study Area 1 and Study Area 2) 

10. Enable editing ; 
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11. In the “Digitizing toolbox” plugin toolbar, ensure that “Split selected multi-part features into 

single part” is enabled; 

 

12. Click on the relevant icon, , to split selected parts. Turn off editing ; 

13. Select the Processing menu tab; 

14. Select Toolbox; 

15. In the search bar type, ‘Merge’; 

16. Select “Merge Vector Layers” under the Vector General dropdown;  

17. Click on the icon containing three dots to right of the Input layers option; 

 

18. Select the temporary “Difference” layer and the relevant neighbouring mangrove extent 

shapefile, click Ok; 

19. Define the relevant CRS; 
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20. Allow a temporary layer to be created, ensure the “Open output file after running algorithm” box 

is checked; 

21. Select the Vector menu tab; 

22. Select Geoprocessing Tools; 

23. Select Dissolve; 

24. Select the relevant temporary “Merge” layer as input layer; 

25. Select the three dots to the right of the “Dissolve field(s) [optional]” box; 

 

26. Select the relevant value that represents mangroves and click Ok; 

27. Allow a temporary layer to be created, ensure the “Open output after running algorithm” box is 

checked; 

28. Working with the temporary “Dissolved” select the only feature and, after enabling editing , 

use the Digitizing Tools toolbar to “Split selected multi-part features to single part” . Turn off 

the editing mode  (this may take some time to save); 

N.B. this process of dissolving to re-split allows the merger of the two study areas to be seamless. That is, 

that two adjacent polygons from each shapefile join to become one polygon.  

29. Right click on the relevant temporary “Dissolved” layer (it will now include multiple features) and “Save 

Features As” a relevant interim combined layer. 
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30. Repeat the above steps using the interim combined layer and the next adjacent study area until all 

layers are combined into a final, overall mangrove cover shapefile.  

In order for this to be successful, the relevant units must already be set (see Section 0). 

9. Open the overall mangrove cover shapefile; 

10. Right click on the layer in the layers viewer panel; 

11. Select “Open Attribute Table”; 

 

12. Open the field calculator ; 

13. Ensure the “Create a new field” box is checked; 

14. Enter “Area” into the “Output field name” box; 

15. Select “Decimal number (real)” from the drop down menu; 

16. Select the preferred output length and precision (recommended 10 and 3); 

17. From the function dropdowns expand “Geometry” and double click on “$area” so that it appears 

in the expression box;  

18. Click Ok, then turn of editing  to save the new attribute field. 

Splitting the overall shapefile to develop administrative regional cover shapefiles 

In order to this, access to the EAME developed “Admin_10km_Offshore.shp” file has been assumed.  

1. Open both the “Admin_10km_Offshore.shp” and the overall extent shapefiles; 

2. Working with the “Admin_10km_Offshore” select the intended administrative region; 

3. Open the Vector menu tab and select “Geoprocessing Tools”; 

4. Open “Clip”; 

5. Set the “Input layer” as the overall extent shapefile; 
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6. Set the “Overlay layer” as the “Admin_10km_Offshore” shapefile and ensure the “Selected 

features only” box is checked; 

7. Click on the three dots to the right of the “Clipped” box and select “Save to file”. Save the 

regional cover shapefile to a relevant location with a relevant name; 

8. Click “Run”; 

 

9. The area for each newly generated shapefile will have to be regenerated, otherwise the areas 

attributed for the overall shapefile will be retained; 

10. Repeat steps selecting each consecutive administrative region in the 

“Admin_10km_Offshore.shp” file to generate all regional shapefiles. 

 Trouble Shooting 

A number of these processes (most specifically the “difference” function) have the potential to develop 

geometry errors within the shapefiles features. This will often mean subsequent processes (i.e. “merge” or 

“clip”) are unable to run and will result in an error such as that shown below.  



 

NORTH BRAZIL SHELF MANGROVE PROJECT | MANGROVE COVER OF GUYANA SOP P A G E  |  37 

 

 

There are two simple methods of repairing this generated geometry error. One uses the “Buffer” and the 

other uses the “V.Clean”. One or the other or sometimes a combination of both tools will often solve this 

problem. Checking a layers validity is also a useful function that is described below. 

Buffer 

This process simply generates a new shapefile with new geometry through a process of buffering the old 

features with a distance value of zero. To do this: 

1. Open the Vector menu tab and select “Geoprocessing tools”; 

2. Open “Buffer”; 

3. Set the relevant shapefile as the “Input layer”; 

4. Set the “Distance” value to 0.0; 

5. Leave all other settings as they are but select the three dots to the right of “Buffered” to 

appropriately save the generated file; 

6. Click “Run”. 
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V.Clean 

This process requires that the combined software package “QGIS Desktop 3.4.10 with GRASS 7.6.1” has 

been opened.  

1. Click on the “Processing” menu tab and open the “Toolbox”; 

2. In the search bar, type “v.clean”; 

3. Open the “GRASS” dropdown menu and then the “Vector” dropdown menu; 

4. Double click on “v.clean” to open the tool; 

5. Select the required shapefile as the “Layer to clean”; 

6. Leave all other settings as found; 

7. Click on the three dots to the right of the “Cleaned” box to save the repaired file appropriately; 

8. Allow the “Errors” box to “Save a temporary file”; 

9. Click “Run”. 
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Checking geometry validity 

1. Open the Vector tab and select “Geometry tools”; 

2. Open “Check Validity”; 

3. Select the relevant shapefile as the “input layer”; 

4. Allow “Invalid output”, “Valid output” and “Error output” to each “Create temporary layer”; 

5. Click “Run”. 

This will generate three separate, temporary shapefiles that can each be interrogated to establish the 

validity and errors of the original shapefiles geometry.  
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 Determination of Mangrove Extent Change 

The determination of change relies on a baseline dataset that can be considered alongside data developed 

by following the methodologies outlined in Section 2.1. EAME used Global Mangrove Watch (GMW) data 

from the years 2009 and 2018. EAME developed change data between the GMW data sets from 2009 to 

2016 and between GMW data and generated data from 2016 to 2018. This was done region by region 

following the below methodology: 

1. Open the two relevant shapefiles (one for time period of the same location, i.e. Admin Region 

1, GMW 2016 and EAME 2018); 

2. Select the Vectors tab from the menu bar, then “Geoprocessing Tools”; 

3. In order to generate a Gain layer, select the early data (i.e. GMW 2016) as the “Input layer” and 

the later data (i.e. EAME 2018) as the “Overlay Layer”; 

4. Use the button with three dots  to the right of the “Difference” box to appropriately save the 

new shapefile; 

5. Click “Run” 
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6. In order to create a Loss layer repeat steps 2 to 5 this time reversing the input and overlay 

layers; 

7. Calculate the areas for the Loss shapefile and the Gain shapefile following the methodology 

outlined in Section 0; 

8. Repeat steps 2 to 7 for each Administrative region; 

9. It may be necessary to merge all regional Loss and all regional Gain files, this can be done 

following the same methodology outlined in Section 4; 

10. Area will have to be re-calculated for the merged shapefiles.  
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 Appendix 1 Data 

Mangrove Cover GIS Data 

Click the link below to access the datasets from the study.  

https://conservation.sharepoint.com/:f:/t/anon/guyana/Eg6EbjNF6vZAupTCnkqIemIBubAxPuP-

rZwXqx7JLdG2BA?e=4tUYeh 
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